Mise à niveau de phpmyadmin (et autres paquets) sur Debian Squeeze

Je viens de configurer une nouvelle VM avec Debian Squeeze (dernière version stable, 6.0.4). Je vais pour un serveur web, donc j’ai installé les habituelles … apache, php5, mysql, phpmyadmin, etc.

Tout s’est bien passé, tout fonctionne.

Ma question concerne la mise à niveau des paquets. J’ai remarqué que la version phpmyadmin est 3.3.7 … la dernière est 3.4.10.1. Faire apt-get update / upgrade ne met pas à jour le paquet.

Comment fait-on pour mettre à jour les paquets sur un serveur Debian Squeeze si apt-get update / upgrade ne fonctionne pas?

Merci!

Vous pouvez télécharger la dernière version depuis la page officielle et suivre les instructions à l’intérieur du fichier compressé pour l’installation.

Si vous souhaitez utiliser les référentiels debian, vous pouvez également append

deb http://ftp.us.debian.org/debian testing main consortingb non-free 

dans le fichier /etc/apt/source.list

Ajoutez aussi

 Package: * Pin: release n=testing Pin-Priority: 500 

dans / etc / apt / preferences

En faisant cela, vous aurez tous les paquets pour la version de test, mais ils ne vont pas être installés à moins que vous ne le spécifiiez, donc lancez

 apt-get update apt-get install = 

par exemple

 apt-get install phpmyadmin=3.4.10.1-1 

vous pouvez vérifier les différentes versions avec

 apt-cache showpkg phpmyadmin