PHP A cessé de travailler avec Apache

J’ai la ligne suivante décommentée dans httpd.conf:

LoadModule php5_module libexec/apache2/libphp5.so 

Lorsque je vais sur une page PHP, le fichier est téléchargé au lieu d’être affiché dans le navigateur. J’ai vérifié que si je me rendais sur une page html, la page s’afficherait correctement pour qu’elle soit liée à PHP.

Ce qui est étrange, c’est que ça marchait bien depuis que j’ai commencé à utiliser cet ordinateur Mac, mais soudainement, ça a cessé de fonctionner. La seule chose à laquelle je puisse penser est la mise à jour de Slack, mais cela ne semble pas avoir de lien avec cela.

Une autre chose étrange est que mon outil de ligne de commande (drush) qui utilise le même php fonctionne.

Je ne peux pas penser à ce que cela peut être.

J’ai essayé d’utiliser Homebrew pour installer une autre version de php mais le problème persiste.

Cela se trouve dans le journal des erreurs apache lorsque je lance la commande apachectl restart:

 [Tue Jan 19 16:56:12.370590 2016] [mpm_prefork:notice] [pid 994] AH00169: caught SIGTERM, shutting down [Tue Jan 19 16:56:12.600054 2016] [mpm_prefork:notice] [pid 1005] AH00163: Apache/2.4.16 (Unix) PHP/5.5.30 configured -- resuming normal operations [Tue Jan 19 16:56:12.600123 2016] [core:notice] [pid 1005] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND' 

Je ne vois aucune erreur dans mon journal des erreurs php ou quelque chose dans le journal des erreurs apache (sinon ce que j’ai spécifié ci-dessus après avoir exécuté la commande).

S’il vous plaît assurez-vous que AddType correct pour php est application / x-httpd-php

Application AddType / x-httpd-php Application .php AddType / x-httpd-php-source .phps

Assurez-vous également que votre module php est chargé

LoadModule php5_module modules / mod_php55.so